import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\d)(?!\\2)(\\d)(?!\\2|\\3)(\\d)(?!\\2|\\3|\\4)(\\d)(?!\\2|\\3|\\4|\\5)(\\d)(?!\\2|\\3|\\4|\\5|\\6)(\\d)(?!\\2|\\3|\\4|\\5|\\6|\\7)(\\d)(?!\\2|\\3|\\4|\\5|\\6|\\7|\\8)(\\d)(?!\\2|\\3|\\4|\\5|\\6|\\7|\\8|\\9)(\\d))(?:,(?1))*\n"
+ "$";
final String string = "123456789,123456789,123456789\n"
+ "123456789\n"
+ "123456789,123456789\n"
+ "123456789,123456781\n"
+ " ^";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}