import Foundation
let pattern = #"^([-\w\d\.]+?)(?(?=_)|(?=\.jpg))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
EAR-LESS2.P.jpg
EAR-LONG.jpg
EAR-SPAR1.jpg
EAR-SUST.H.jpg
EAR-TANYIN.jpg
EF-GILD.H.jpg
EFR-CHASD2.jpg
EL-GOIN.P.jpg
EL-LOVE.jpg
EM-CHAS.jpg
EM-GARD.jpg
EM-MENW.jpg
EM-TENK.jpg
EM-THIR.H.jpg
EM-WHATC.P.jpg
EMO-ANTI.S_1.jpg
EMO-SOUN.jpg
EO-AMIL1.jpg
EO-BIURT.jpg
EO-CHASI.jpg
EO-ETER.jpg
EO-FOUR.jpg
EO-GPSHM.H.jpg
EO-HAPP.jpg
EO-INNEW.jpg
EO-JEWIBLAL.jpg
EO-JEWIL.jpg
EO-LETTOL.jpg
EO-PARSM2.jpg
EO-PRAYPO1.jpg
EO-SECO.jpg
EO-SPIR.jpg
EO-TEACAHP.jpg
EO-TEFI.jpg
EO-THIN.jpg
EO-TOBE.jpg
EO-UPSH.jpg
EO-VISU.jpg
EO-YAHASP.jpg
EP-STH.SFLE.jpg
ERE-BEYO.jpg
ERE-BRIN.L.jpg
ERE-BRIN.M.jpg
ERE-MIND.jpg
ERE-ONEBO.jpg
ERE-PROC4.jpg
ERE-TOWA.p.jpg
HAR-LIKUAHS_1.jpg
HAR-SHAAYVITPK.jpg
HAR-SM64.jpg
HAR-TANYCM5.jpg
HAR-TANYCM7.jpg
HFR-MAAM1.jpg
HFR-MAAM3.jpg
HFR-ZICH.S_1.jpg
HFR-ZICH.S_2.jpg
HH-TOLDCP.jpg
HH-TOLDCRT.jpg
HKO-28SIVA.jpg
HMR-ATER.jpg
HMR-SMD2.jpg
HO-CHON.S_1.jpg
HO-CHON.S_3.jpg
HO-HASH3.jpg
HO-HASH4.jpg
HO-TANYLKV.jpg
HO-TISH.jpg
HO-YALKLY1.jpg
HO-YALKLY3.jpg
HO-YALKLYMC.jpg
HO-YAMITPE.jpg
HP-HAGG.KITZEE.jpg
HP-HAGG.S_1.jpg
HP-HAGG.Y.jpg
HP-STH.NSGR.jpg
HP-STMH_1.jpg
HRE-BIURBR_2.jpg
HRE-HAME_1.jpg
HRE-HAME_2.jpg
HRE-HASIS.jpg
HRE-HAYO.MEV_2.jpg
HRE-HAYOYMH.jpg
HRE-MAAY.jpg
HRE-OTSALSKY.jpg
HRE-SHAAEY.jpg
HRE-SHAAMYO.jpg
HRE-SHAAMYU.jpg
HRE-SMMC.jpg
HRE-SMMRH.jpg
HRE-TM1.l.jpg
HRE-TM10.jpg
HRE-TM18.jpg
HRE-TM21.jpg
HRE-TM30.jpg
HRE-TM35.jpg
HRE-TM37.jpg
HRE-TM41.jpg
HRE-TM54.jpg
HRE-TM57.jpg
HRE-TM62.jpg
HRE-TM71.jpg
HRE-TMMAFT_1.jpg
HRE-TMTLYV.OLD.jpg
HRE-VEAT.jpg
HRR-SM72BESH1.jpg
HRR-SM72BESH3.jpg
HTZ-HACH.jpg
HTZ-MAFT.jpg
HTZ-OHBA3.jpg
HTZ-OHBR5.jpg
HTZ-OHBR6.jpg
HTZ-OHD2.jpg
HTZ-OHD3.jpg
HTZ-OHN1.jpg
HTZ-OHN3.jpg
HTZ-OHS5.jpg
HTZ-OHS6.jpg
HTZ-OHSH1.jpg
HTZ-OHSH2.jpg
HTZ-OHSH2.jpg
HTZ-SLA3.jpg
HTZ-SLA4.jpg
HTZ-SLC1.jpg
HTZ-SLC2.jpg
HTZ-SLK.jpg
HTZ-SLM3.jpg
HTZ-SLMA.jpg
HTZ-SLMI.jpg
HTZ-SLS.jpg
HTZ-SLY3.jpg
HTZ-SMH1.jpg
efr-ss98.jpg
el-shabp.jpg
em-some.jpg
eo-248p.jpg
eo-jewi1.jpg
eo-littbbi.jpg
ep-sibc.ws.jpg
ere-beac.jpg
ere-holi.sb_1.jpg
ere-seek.jpg
ese-talk.p.jpg
har-shiu.s_2.jpg
har-shiu.s_3.jpg
har-tany.loh.jpg
hfr-ik10.jpg
hfr-ik11.jpg
hfr-ik15.jpg
hfr-ik17.jpg
hfr-ik6.jpg
hfr-likud.s_1.jpg
hfr-sm80.jpg
hfr-sm92.jpg
hku-tziy.jpg
ho-biurl.jpg
ho-yeso.jpg
hp-sth.ln.jpg
hp-tehi.l.jpg
hre-ik11.jpg
hre-ik13.jpg
hre-ik14.jpg
hre-ik15.jpg
hre-ik16.jpg
hre-ik18.jpg
hre-ik2.jpg
hre-ik20.jpg
hre-ik22.jpg
hre-ik23.jpg
hre-ik27.jpg
hre-ik31.jpg
hre-ik33.jpg
hre-ik4.jpg
hre-ik5.jpg
hre-ik9.jpg
hre-ikm1.jpg
hre-ikm3.jpg
hre-klalrs.jpg
hre-ls2.jpg
hre-ls26.jpg
hre-ls28.jpg
hre-ls32.jpg
hre-ls36.jpg
hre-otsaik.jpg
hre-shaag_1.jpg
hre-smm.s_1.jpg
hre-smm.s_4.jpg
hrm-ik.jpg
hrm-sm26.jpg
hrm-sm28.jpg
hrm-sm32.s_2.jpg
hrm-sm33.s_1.jpg
hrm-sm37.s_1.jpg
hrm-sm41.jpg
hrr-ik3.jpg
hrr-ik5.jpg
hrr-sm43.jpg
hrr-sm52.jpg
hrr-sm59.jpg
hrr-sm66yomt.jpg
hrr-sm69.jpg
hrr-sm79.jpg
htz-tzemtoc_1.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)