import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:-.*\\n){3}-((?:.*\\n(?!-).*)*)";
final String string = "-match one\n"
+ "-match two\n"
+ "-match three\n"
+ "-and a bunch of notes here, potentially with more than 1 line or newlines included \n"
+ "and there may be hyphens in this text as well\n\n"
+ "-match one\n"
+ "-match two\n"
+ "-match three\n"
+ "-and a bunch of notes here, potentially with more than 1 line or newlines included \n"
+ "and there may be hyphens in this text as well\n\n"
+ "This is a - text\n\n"
+ "---------- Forwarded message ----------\n"
+ "From:....";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}