re = /37\|\\":\\"\K\d*/m
str = '{"|1|":"A","|2|":"B","|37|":"4234235","|4|":"C"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end