package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(private|public) ([A-Za-z_][A-Za-z_0-9.]*) ?\(((.*,)*.*)\) ?\{(.*)\}`)
var str = `public aboba(str in, box[int a, int b] c) {return $std:convert.toInt(in) + c;};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}