$re = '/(?<=\b5\()(\d+?)(?=\))/';
$str = '5(70);15(75);5(57)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);