package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*(?:[^*]|\*++[^\/])*+\*++\/`)
var str = `/*co*mm1*//*co**mm2**/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}