const regex = /0(?=0*1)/gy;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0(?=0*1)', 'gy')
const str = `00100100`;
const subst = `2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);