#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\s{0,5}<\s{0,5}\*\s{0,5}<(.*?)>\s{0,5}>\s{0,5}\*\s{0,5}>"
Local $sString = "< < * < • 1 2 3 > <<0 12345®789>> * * < < 1 2 > <<0 123456<89>>*> >" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")