$re = '/^(?=.{10,255}$)(?=.{4,64}@)[A-z0-9]+(?:[.-][A-z0-9]+)*@[A-z0-9]+(?:[.-][A-z0-9]+)*\.[A-z]+$/mu';
$str = 'a-b.de@fn.cdpdodo
df
-abde@fn.co
_abde@_fn.co
.abde@fn.co
abde_@fn.co
ab_de@_f------n.co
abdسيبe@fn.co
abde@fn.co
ab_nnnn___0---....................-----de@fn.f.co
abde@.fn.f.co
.......abde@fn.f.co
fkb-----kkkabde@fn.f.co
f3.f3.f3.f3.fff3@gmail.com
qowijdoqiwjdoqwi@coeoicmoei.ecpomep.d.docimequo
a23456789a123456789b123456789c123456789d123456789e123456789f1234@a23456789a123456789b123456789c123456789d123456789e123456789f1234a23456789a123456789b123456789c123456789d123456789e123456789f1234a.a23456789a123456789b123456789c123456789d123456789e123456789f1234a
wijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwij@coeo444--icmoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocime
[\\w.-]{2,}\\.[A-z]{2,}
^[A-z0-9][\\w.-]{0,64}[A-z0-9]@(?:[A-z0-9-]{1,63}\\.){1,3}[A-z]{2,63}$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);