re = /^\{{19}(\{[^{}]+\})\}{19}$/m
str = '{{{{{{{{{{{{{{{{{{{{Valor aqui dentro}}}}}}}}}}}}}}}}}}}}
{{valor aqui dentro}}
{{valor aqui dentro}
{{valor aqui dentro}}}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end