# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<[ul|ol][^>]*?style=\"[^>]*?)(list-style-type:[a-zA-Z0-9:\.\s\(\)\-\,]*;?)([^\"]*\"[^>]*?>)"
test_str = ("<ul style=\"list-style-type:disc\">\n"
"<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut\n"
"<ul style=\"list-style-type:circle\">\n"
"<li>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</li>\n"
"<li>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</li>\n"
"<li>In voluptate velit esse cillum dolore eu fugiat nulla pariatur.\n"
"<ul style=\"list-style-type:square\">\n"
"<li>Excepteur sint occaecat cupidatat non proident.</li>\n"
"<li>Sunt in culpa qui officia deserunt mollit anim id est laborum.</li>\n"
"</ul>\n"
"<ul style=\"list-style-type:square; abc:asd; qwe:10pt\">\n"
"<ul style=\"aaa:eeee; list-style-type:square; abc:asd; qwe:10pt\" asdas=\"aeee\">\n"
"<ul asdsa=\"eee\" style=\"aaa:eeee; list-style-type:square; abc:asd; qwe:10pt\" asdas=\"aeee\">\n\n"
"<ul style=\"list-style-type:circle;\"><li cke:reset=\"1\" cke:indent=\"1\" cke:listsymbol=\"o\" style=\"\"><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span><ul style=\"list-style-type:square;\"><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut</span></li><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span></li><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur. </span><ul style=\"list-style-type:disc;\"><li cke:indent=\"3\" cke:listsymbol=\"·\" style=\"\"><span></span><span>Excepteur sint occaecat cupidatat non proident.</span></li><li cke:indent=\"3\" cke:listsymbol=\"·\" style=\"\"><span></span><span>Sunt in culpa qui officia deserunt mollit anim id est laborum.</span></li></ul></li></ul></li><li cke:indent=\"1\" cke:listsymbol=\"o\" style=\"\"><span></span><span>aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit</span><ul style=\"list-style-type:square;\"><li cke:indent=\"2\" cke:listsymbol=\"§\" style=\"\"><span></span><span>In voluptate velit esse cillum dolore eu fugiat nulla pariatur.\n"
"<ol style=\"list-style-type:lower-roman;\"> ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.