$re = '/^[ab]([ab])[ab]*[ab]$(?<!\1)/m';
$str = 'aaabbbbababab
aaabbbbababaa
ababbbbababab
ababbbbababaa
abb
aba
aab
aaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);