#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<name>[\w\-\.]+)-(?P<version>v?\d+(\.\d+)?(\.\d+)?(-[\w\-]+(\.[\w\-]+)*)?(\+[\w\-]+(\.[\w\-]+)*)?)(?P<ext>\.[\w\-]+)$"
Local $sString = "ansi-escapes-4.3.1.tgz" & @CRLF & _
"babel-eslint-10.1.0.tgz" & @CRLF & _
"chance-1.1.7.tgz" & @CRLF & _
"cli-cursor-3.1.0.tgz" & @CRLF & _
"eslint-7.13.0.tgz" & @CRLF & _
"faker-5.1.0.tgz" & @CRLF & _
"forever-monitor-3.0.1.tgz" & @CRLF & _
"fs-extra-9.0.1.tgz" & @CRLF & _
"lorem-ipsum-2.0.3.tgz" & @CRLF & _
"micromatch-4.0.2.tgz" & @CRLF & _
"mongoose-5.10.13.tgz" & @CRLF & _
"puppeteer-5.4.1.tgz" & @CRLF & _
"puppeteer-extra-3.1.15.tgz" & @CRLF & _
"puppeteer-extra-plugin-stealth-2.6.3.tgz" & @CRLF & _
"random-email-1.0.3.tgz" & @CRLF & _
"random-useragent-0.5.0.tgz" & @CRLF & _
"random-words-1.1.1.tgz" & @CRLF & _
"slice-ansi-4.0.0.tgz" & @CRLF & _
"uuid-8.3.1.tgz" & @CRLF & _
"validator-13.1.17.tgz" & @CRLF & _
"wrap-ansi-7.0.0.tgz" & @CRLF & _
"font-awesome-5.11.2.tgz" & @CRLF & _
"react-dom-16.13.1.tgz" & @CRLF & _
"bootstrap-4.5.2.tgz" & @CRLF & _
"moment-duration-format-2.3.2.tgz" & @CRLF & _
"imagesloaded-4.1.tgz" & @CRLF & _
"flickity-2.0.tgz" & @CRLF & _
"lomster-1.tgz" & @CRLF & _
"unicorn-1.2.3-alpha.10.beta.0.tgz" & @CRLF & _
"rainbow-v1.1.1.tgz" & @CRLF & _
"object.assign-4.1.4.tgz" & @CRLF & _
"hello_world-0.0.3.tgz" & @CRLF & _
"typescript-package-1-1.0.2.tgz" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")