import re
regex = re.compile(r'authorName\s+=\s+"([^"]*)"', flags=re.MULTILINE)
test_str = "teacher a prime example of where SF should invest windfall\";var omni_bizObjectId = \"13560483\";var omni_className = \"article\";var omni_publicationDate = \"2019-01-25T12:00:00+00:00\";var omni_sourceSite =\"sfgate\";var omni_authorName = \"Heather Knight\";var omni_authorTitle = \"\";var omni_premiumStatus = \"isPremium\";var omni_premiumEndDate = \"1893506400\";var omni_originalSource = \"SF\";var omni_pageNumber = \"1\";var omni_breakingNewsFlag = \"0\";var omni_localNewsFlag = \"1\";var omni_isListView = \"0\";var omni_paywallSite = \"1\";var omni_displayTemplate = \"ard\";"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")