$re = '/\b(?<=crossing_success\[|series120_count\[)\d+(?=])/m';
$str = 'series120_count[1]; crossing_success[2]; tag_comments[small]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);