# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<name>[^.,?;:\s]+)$|^(?:(?<honorific>(?:mrs?|ms|dr|prof|rev|hon)\.?|miss|sir|dame|lord|lady)\s+)?(?:(?<given_name>(?<first_name>[^.,?;:\s]+\.?)(?:\s+(?<middle_name>(?:[^.,?;:\s]+\.?)(?:\s+[^.,?;:\s]+\.?)*?))??)\s+)??(?:(?<family_name>(?:(?:(?:(?:a|ab|af|ap|abu|aït|al|ālam|at|ath|aust|austre|bar|bath|bat|ben|bin|ibn|bet|bint|da|das|de la|degli|del|dele|della|der|di|dos|du|e|el|fetch|vetch|fitz|i|ka|kil|gil|la|le|lille|lu|m'|mac|mc|mck|mhic|mic|mala|mellom|myljom|na|ณ|ned|nedre|neder|ngā|nic|ní|nin|nord|norr|ny|o|ó|ua|uí|opp|upp|öfver|ost|öst|öster|øst|østre|över|øvste|øvre|øver|öz|pour|putra|putera|putri|puteri|setia|setya|stor|söder|sør|sønder|syd|søndre|syndre|søre|te|ter|ter|tre|van|van de|van den|van der|van het|van 't|väst|väster|verch|erch|vest|vestre|vesle|vetle|von|war|zu|von und zu)\s)?[^.,!?;:\s]+)-)?(?:(?:a|ab|af|ap|abu|aït|al|ālam|at|ath|aust|austre|bar|bath|bat|ben|bin|ibn|bet|bint|da|das|de la|degli|del|dele|della|der|di|dos|du|e|el|fetch|vetch|fitz|i|ka|kil|gil|la|le|lille|lu|m'|mac|mc|mck|mhic|mic|mala|mellom|myljom|na|ณ|ned|nedre|neder|ngā|nic|ní|nin|nord|norr|ny|o|ó|ua|uí|opp|upp|öfver|ost|öst|öster|øst|østre|över|øvste|øvre|øver|öz|pour|putra|putera|putri|puteri|setia|setya|stor|söder|sør|sønder|syd|søndre|syndre|søre|te|ter|ter|tre|van|van de|van den|van der|van het|van 't|väst|väster|verch|erch|vest|vestre|vesle|vetle|von|war|zu|von und zu)\s+)?[^.,?;:\s]+)??(?:,?\s+(?<suffix>Sr\.?|Snr|Jr\.?|Jnr|[IVX]+))?)?(?<post_nominal>,.*)?$"
test_str = ("John Doe\n"
"Mary Jane Smith\n"
"Jean-Luc van der Berg, Sr.\n"
"Maria de la Cruz\n"
"Mohamed bin Ahmed al-Farsi\n"
"Anna-Nicole Johnson Jr.\n"
"Carlos Alberto dos Santos\n"
"Sophie von und zu Rhein\n"
"Li Na\n"
"O'Connor Fitzpatrick III\n"
"Yusuf ibn Abdullah\n"
"Emma-Louise O'Reilly\n"
"Juan Carlos de la Torre\n"
"Fatima bint Mohammed\n"
"Hans-Christian Andersen\n"
"Elena di Matteo\n"
"Abdul-Rahman al-Hashimi\n"
"Isabella della Rovere\n"
"Jean-Pierre Dupont, Jr\n"
"Sara van den Berg\n"
"John Q. Public\n"
"Dr. Jane Doe, PhD\n"
"Prof. John Smith, MD\n"
"Mr. James Walter Thomas Jr.\n"
"Ms. Emily Davis, CPA\n"
"Dr. Michael David Jacob Brown, DDS\n"
"Mrs. Sarah Wilson, RN\n"
"Rev. Thomas Anderson, DD\n"
"Mr. Adams\n"
"T'Challa\n"
"ǃXóõ ǁKaru\n"
"ǃHõã ǂNuka\n"
"J. K. Rowling\n"
"John Jacob Jingleheimer Schmidt")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.