# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(:\n\s))(?:\s|\n|(?:.(?!modern))*)*"
test_str = ("js/modern/redux/actions/open-file-in-new-window.js:\n"
" 8 import { openWindow, maybeSetVariantRedirectDomainQueryParam } from '@slack/infra/multi-window';\n"
" 9: import getPrimaryView from '@slack/redux/stores/workspace-store/get-primary-view';\n"
" 10 import { isGovSlack } from '@slack/utility/is-gov-slack';\n\n"
" 26 const teamId = getTeamId(team);\n"
" 27: const conversationId = getPrimaryView(state);\n"
" 28 let fileUrl = teamId\n\n"
"js/modern/redux/actions/open-shortcuts-menu.js:\n"
" 10 import looksLikeChannelId from '@slack/utility/looks-like-channel-id';\n"
" 11: import getPrimaryView from '@slack/redux/stores/workspace-store/get-primary-view';\n"
" 12 import jumpToMessage from '@slack/redux/actions/jump-to-message';\n\n"
" 25 const state = getState();\n"
" 26: const primaryViewId = getPrimaryView(state);\n"
" 27 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.