$re = '/<div id=\'pump\'><font size="25" color="blue">(.*)<\/font><\/div><br>/m';
$str = '<html lang="ru">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>KНС-16</title>
</head>
<body>
<font size="20" color="blue"> KHC-16 </font><br><br>
<div id=\'pump\'><font size="25" color="blue"> HACOC ОТКЛЮЧЕН -</font></div><br>
<div id=\'amp\'><h1>Амперы= 0</h1></div>
<div id=\'door\'><h1>Дверь:</h1><font size="15" color="red">ОТКРЫТА</font></div><br><br>
<h1>YPOBEH </h1>
<div id=\'level_up\'><font size="15" color="green">НИЖНИЙ</font></div><br>
<div id=\'level_bootom\'><font size="15" color="red">ВЕРХНИЙ</font></div><br>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);