#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(\w+:\w+\)"
Local $sString = "['OncoMed Pharmaceuticals Inc. (OMED:NASDAQ)', ' , a company "we\'ve had a long-term passion for." He considers OncoMed a "leader in the cancer stem cell space," with a number of clinical assets including a handful that are proprietary, and many partnered with larger-cap pharmas and biotechs. Among the candidates slated for either clinical trials or data readouts in 2017 is demcizumab, in pancreatic cancer. "We think it will be a key catalyst for the shares," King said. Other assets include tarextumab, for a small cell lung cancer; DLL4/VEG4, also in non-small cell lung cancer; and "a new asset that was previously known as I/O#2. . .a very highly validated immuno-oncology target called TIGIT," in development in partnership with Celgene Corp. (CELG:NASDAQ).']" & @CRLF & _
"['King called Syndax Pharmaceuticals Inc. (SNDX:NASDAQ) "a hybrid story. " The company is a player in the immuno-oncology space as well as in the "broader" cancer world with a drug called entinostat, which is in Phase 3 in metastatic breast cancer. Readouts on overall survival aren\'t expected until 2019, but King is "optimistic about Syndax\'s chances for success in the Phase 3 trial." The company is also in collaborations with major pharmas in the "immune checkpoint space," with data expected to "roll out over the course of 2017."']" & @CRLF & _
"['Syros Pharmaceuticals (SYRS:NASDAQ) is an early-stage company, with a ~$250M market cap, that King considers a leader in gene regulation, with a concept called super-enhancers. The company both develops its "own internal candidates to some of the highly validated targets," as well as repurposes assets that may have been abandoned for indications like blood disorders. Syros might be "a quiet story the first half of 2017, but I think in the second half of 2017, we\'ll start to see some firewor"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")