#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\r\n]+\[\d{4}-\d{2}-\d{2}\s+\d{2}:\d{2}:\d{2}\.\d+-\d{2}:\d{2}\|info]\*[^\r\n]+([\r\n]+)\[\d{4}-\d{2}-\d{2}\s+\d{2}:\d{2}:\d{2}\.\d+-\d{2}:\d{2}\|info\]Line"
Local $sString = "[2019-12-18 07:00:01.070924-07:00|info]Line 3: :begin" & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]Line 4: " & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]Line 5: WORKINGDIR "C:\Download\Server1"" & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]*Working directory: C:\Download\Server1\" & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]Line 6: " & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]Line 7: FTPLOGON "Server1" /timeout=60" & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]*Logging on to <server1> as SFTP (SSH File Transfer Protocol)" & @CRLF & _
"[2019-12-18 07:00:01.070924-07:00|info]*Logon in progress..." & @CRLF & _
"[2019-12-18 07:00:03.055523-07:00|info]*Logon successful." & @CRLF & _
"[2019-12-18 07:00:03.055523-07:00|info]Line 8: FTPCD "Extracts"" & @CRLF & _
"[2019-12-18 07:00:03.164909-07:00|info]*Current FTP site directory: /Extracts/" & @CRLF & _
"[2019-12-18 07:00:03.164909-07:00|info]Line 9: IFERROR= $ERROR_SUCCESS GOTO Operation1" & @CRLF & _
"[2019-12-18 07:00:03.164909-07:00|info]Line 21: :Operation1" & @CRLF & _
"[2019-12-18 07:00:03.164909-07:00|info]Line 22: FTPGETFILE "*na_alert_subs*" /newest" & @CRLF & _
"[2019-12-18 07:00:03.164909-07:00|info]*Hint: FTPGETFILE /newest always returns the newest file" & @CRLF & _
"[2019-12-18 07:00:03.430561-07:00|info]Line 22: *%sitefile has been set to: na_alert_subs_20191217.txt" & @CRLF & _
"[2019-12-18 07:00:03.446223-07:00|info]Line 23: RCVFILE %sitefile /delete" & @CRLF & _
"[2019-12-18 07:00:03.446223-07:00|info]*Receiving to "C:\Download\Server1\na_alert_subs_20191217.txt"" & @CRLF & _
"[2019-12-18 07:00:12.947244-07:00|info]*Complete, received 1394788 bytes in 9 seconds (1513.44K cps)" & @CRLF & _
"[2019-12-18 07:00:13.103506-07:00|info]*File deleted on FTP site." & @CRLF & _
"[2019-12-18 07:00:13.103506-07:00|info]*Download complete, 1 file received." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")