re = /(?<!```)[^`]*(?<=`)[^`\n]+(?=`)[^`]*(?!```)/m
str = '
``` `Hello world` ```
`Matched!`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end