import re
regex = re.compile(r"\S.+CONTRIBUTE A TEST\r?$", flags=re.MULTILINE)
test_str = ("- T1566.002 Spearphishing Link CONTRIBUTE A TEST\n"
"- T1566.003 Spearphishing via Service CONTRIBUTE A TEST\n"
"- T1195 Supply Chain Compromise CONTRIBUTE A TEST\n"
"- T1199 Trusted Relationship CONTRIBUTE A TEST\n"
"- T1078 Valid Accounts CONTRIBUTE A TEST")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")