const regex = /(\s|^)(\d(,|\.){0,1})+(\s*)(dollar|\$|dollars)(\s|,|\.|$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s|^)(\\d(,|\\.){0,1})+(\\s*)(dollar|\\$|dollars)(\\s|,|\\.|$)', 'mg')
const str = `shirt on sale 20-40% green price 20-30\$ sale 20\$, 20dollars`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}