#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(?<time>[^\]]*)\] (?<level>[^:]*):\s+(?<reason>.+?) \/[^\/]*\/(?<repo>[^\/]*)\/[^\/]*\/(?<release>[0-9]*)\/(?<file>[^\s|:]*)[^0-9]*(?<line>[0-9]*)"
Local $sString = "[21-Feb-2019 10:24:23 Europe/Berlin] PHP Warning: SimpleXMLElement::__construct(): 'hostel','other_accommodation','other_accommodation','other_accommodation'), "/> in /srv/hometogo_import/releases/20190221091925/src/Htg/Backend/StandardFeedBundle/Validators/ObjectValidator.php on line 133" & @CRLF & _
"[21-Feb-2019 10:24:23 Europe/Berlin] PHP Warning: SimpleXMLElement::__construct(): ^ in /srv/hometogo_import/releases/20190221091925/src/Htg/Backend/StandardFeedBundle/Validators/ObjectValidator.php on line 133" & @CRLF & _
"[21-Feb-2019 10:23:45 Europe/Berlin] PHP Notice: Undefined index: es_ES in /srv/hometogo_import/releases/20190221071657/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 10:24:23 Europe/Berlin] PHP Warning: SimpleXMLElement::__construct(): Entity: line 1: parser error : Extra content at the end of the document in /srv/hometogo_import/releases/20190221091925/src/Htg/Backend/StandardFeedBundle/Validators/ObjectValidator.php on line 133" & @CRLF & _
"[21-Feb-2019 10:35:53 Europe/Berlin] PHP Notice: Undefined index: en_US in /srv/hometogo_import/releases/20190221071657/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 10:35:53 Europe/Berlin] PHP Notice: Undefined index: es_ES in /srv/hometogo_import/releases/20190221071657/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:43:05 Europe/Berlin] PHP Warning: PDOStatement::execute(): MySQL server has gone away in /srv/hometogo_import/releases/20190221082132/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php on line 105" & @CRLF & _
"[21-Feb-2019 09:43:05 Europe/Berlin] PHP Warning: PDOStatement::execute(): Error reading result set's header in /srv/hometogo_import/releases/20190221082132/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOStatement.php on line 105" & @CRLF & _
"[21-Feb-2019 09:10:25 Europe/Berlin] PHP Notice: Undefined index: en_US in /srv/hometogo_import/releases/20190220180846/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:10:25 Europe/Berlin] PHP Notice: Undefined index: es_ES in /srv/hometogo_import/releases/20190220180846/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:10:30 Europe/Berlin] PHP Notice: Undefined index: en_US in /srv/hometogo_import/releases/20190221071657/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:10:30 Europe/Berlin] PHP Notice: Undefined index: es_ES in /srv/hometogo_import/releases/20190221071657/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:10:42 Europe/Berlin] PHP Fatal error: Uncaught RuntimeException: Process interrupted in /srv/hometogo_import/releases/20190221080147/src/Htg/Backend/KafkaBundle/Command/SinkToBufferCommand.php:193" & @CRLF & _
"Stack trace:" & @CRLF & _
"#0 [internal function]: Htg\Backend\KafkaBundle\Command\SinkToBufferCommand->processEnd()" & @CRLF & _
"#1 {main}" & @CRLF & _
" thrown in /srv/hometogo_import/releases/20190221080147/src/Htg/Backend/KafkaBundle/Command/SinkToBufferCommand.php on line 193" & @CRLF & _
"[21-Feb-2019 09:10:42 Europe/Berlin] PHP Notice: Undefined index: en_US in /srv/hometogo_import/releases/20190220180846/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:10:42 Europe/Berlin] PHP Notice: Undefined index: es_ES in /srv/hometogo_import/releases/20190220180846/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:10:42 Europe/Berlin] PHP Warning: PDO::query(): MySQL server has gone away in /srv/hometogo_import/releases/20190221080147/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php on line 104" & @CRLF & _
"[21-Feb-2019 09:10:42 Europe/Berlin] PHP Warning: PDO::query(): Error reading result set's header in /srv/hometogo_import/releases/20190221080147/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php on line 104" & @CRLF & _
"[21-Feb-2019 09:11:54 Europe/Berlin] PHP Notice: Undefined index: en_US in /srv/hometogo_import/releases/20190221071657/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:05:20 Europe/Berlin] PHP Warning: call_user_func() expects parameter 1 to be a valid callback, no array or string given in /srv/hometogo_import/releases/20190221071657/src/Vrt/AggregatorBundle/Writer/Runner/Json.php on line 57" & @CRLF & _
"[21-Feb-2019 09:05:30 Europe/Berlin] PHP Notice: Undefined index: en_US in /srv/hometogo_import/releases/20190220180846/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:05:30 Europe/Berlin] PHP Notice: Undefined index: es_ES in /srv/hometogo_import/releases/20190220180846/vendor/hometogo/data-model/src/Model/DestinationModel.php on line 358" & @CRLF & _
"[21-Feb-2019 09:07:40 Europe/Berlin] PHP Warning: imagecreatefromstring(): Data is not in a recognized format in /srv/hometogo_image/releases/20181119092803/src/Htg/Transform/TransformationManager.php on line 159"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")