import Foundation
let pattern = #"(?<=– )(?:.+)?(?:bzw\.|Z\. b\.|u\. a\.)[^\.]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Sich wie ein Backfisch benehmen – albern bzw. unreif sein. Zur Etymologie des Wortes „Backfisch“ für unreife Mädchen siehe dort. (Sprichwort um 1900: „Mit 14 Jahr’n und sieben Wochen ist der Backfisch ausgekrochen.“[6]).
Kluge Kapitalanleger lassen sich nicht nur bisherige Mietverträge zur Prüfung aushändigen, sondern lassen sich auch den regelmäßigen Mieteingang bescheinigen – Z. b. Einsicht in die Kontoauszüge des Vorbesitzers bekommen.
René Bertholet (ISK; verwendete Pseudonyme – u. a. Pierre Robert, Georg Binder) (Wikipedia).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)