$re = '/(\d{1,2}) December (\d{4})/m';
$str = '25 December 2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);