$re = '/(\w)\1{2,}/m';
$str = 'In this seeentence someone typed sooooooome words by pressssssssing some keys wayyyyyyyy to loooooong. You see?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);