#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http:\/\/mywebsite\.com\/((http:\/\/|www\.)?[a-z]*(\.org|\.co\.uk).*)"
Local $sString = "http://mywebsite.com/yahoo.org/search=xyz" & @CRLF & _
"http://mywebsite.com/www.yahoo.org/search=xyz" & @CRLF & _
"http://mywebsite.com/msn.co.uk" & @CRLF & _
"http://mywebsite.com/http://msn.co.uk" & @CRLF & _
"http://mywebsite.com/index.php"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")