#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)282b:(?<player>[a-zA-Z-' ]{3,30}) readies Terminal Velocity."
Local $sString = "[14:37:04.000] 00:082b:You use Cascade." & @CRLF & _
"[01:00:07.000] 00:102b:Vista CleaveCarbuncle readies Raw Destruction." & @CRLF & _
"[01:17:35.000] 00:102b:Mia MillGungnir readies Raw Destruction." & @CRLF & _
"[01:15:04.000] 00:082b:You use Cascade." & @CRLF & _
"[01:17:01.000] 00:28af:⇒ You suffer the effect of Bind." & @CRLF & _
"[19:14:57.000] 00:28af:⇒ You suffer the effect of Holmgang." & @CRLF & _
"[00:41:42.000] 00:28af:⇒ You suffer the effect of Feint." & @CRLF & _
"[00:39:49.000] 00:292f:⇒ Holo Horizonhollow suffers the effect of Feint." & @CRLF & _
"[00:44:38.000] 00:292f:⇒ Rip RillGungnir suffers the effect of Feint." & @CRLF & _
"" & @CRLF & _
"[01:00:35.000] 00:282b:Zukasa YatohTyphon readies Raw Destruction." & @CRLF & _
"[01:17:00.000] 00:282b:Zukasa YatohTyphon readies Raw Destruction." & @CRLF & _
"[01:16:18.348] 1A:1009238C:Octavian Kreuszner gains the effect of Sleep Resistance from Tuke Mono for 10.00 Seconds." & @CRLF & _
"[22:27:58.041] 1A:1024EAB3:Xi Eanris gains the effect of Sleep Resistance from Rip Rill for 10.00 Seconds." & @CRLF & _
"[00:41:34.000] 00:282b:Agurlius StoreaUnicorn readies Raw Destruction." & @CRLF & _
"[00:41:35.044] 14:D20:Agurlius Storea starts using Raw Destruction on Agunimon Kenbara." & @CRLF & _
"[00:43:19.000] 00:282b:Miqo AtsushieCarbuncle readies Terminal Velocity." & @CRLF & _
"" & @CRLF & _
"[00:40:32.054] 03:40006E89:Added new combatant Adrenaline. Job: N/A Level: 60 Max HP: 4000 Max MP: 100 Pos: (0,-10,-2.5) (46860000006489)." & @CRLF & _
"[21:23:01.720] 03:4000A841:Added new combatant Adrenaline. Job: N/A Level: 60 Max HP: 4000 Max MP: 100 Pos: (0,-10,-2.5) (46860000006489)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")