package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([\w, ]+)\n`)
var str = `one, two, three
four, five, six
seven, eight, nine`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}