using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:-?[0-9]+(?:,(?!$)|$))+$";
string input = @"1,2,3
-1,2,-3
3
4
22,-33
Some examples of forbidden inputs:
22,-33,
1,,2
--1,2,3
-1,2,--3
asdas
[]\%$1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}