$re = '/\b(?:o|(?:(?(1)\1|o)(?=((?(1)\1\1|o))))+\1)\b/';
$str = 'o (1) ooo (3) oooooo (6) oooo (4) ooooooooo (9) oo (2) oooooooooooo (12) oooooooo (8)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);