$re = '/([A-Za-z][a-z]*) (?:\1 ?)+/m';
$str = 'aah aah aah aah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);