const regex = /\d[a-z0-9.-]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d[a-z0-9.-]*', 'gm')
const str = `Examplestreet 1/2.1/3a/10/10.1/11b/12a-12c/13a-c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}