package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{((?:[A-Za-z])+)\}`)
var str = `{AbcdefgF}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}