$re = '/^(0|1)(0|1)(0|1)(0|1)(0|1)-(0|1)(0|1)(0|1)(0|1)-(0|1)(0|1)-(0|1)(0|1)(0|1)$/m';
$str = '01101-0110-01-011
01000-0010-01-010
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);