package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)name\=\"(?<name>[^\"]*)\",value\=\[*\"(?<values>[^\"]*)`)
var str = `name="Building",value="Southwest",descendants_action="success",operation="OVERRIDE"
name="Building",value=["Northeast","Northwest"],descendants_action="failure",operation="OVERRIDE"
name="Building",value="Southeast",descendants_action="success",operation="OVERRIDE"
name="Building",value="Northwest"
name="Building",value="Northwest",operation="OVERRIDE"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}