package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Ząćęłń󿟥ĆĘŁŃÓŻŹ -]+$`)
var str = `Dąćęłńóżźk Ćąćęłńóżź- ŻgAj`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}