import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?<batch_number>\\d{2})-\n"
+ "(?:\n"
+ " (?<component>QQ|CO|CG)\n"
+ " (?<target_group>[AS])\n"
+ " (?<paper>P)?\n"
+ ")\n"
+ "(?:-\n"
+ " (?<domain>(?:LDW|MAT|REA|SCI|XYZ)\n"
+ " (?<division>[abc])?\n"
+ " )\n"
+ ")?\n"
+ "-(?<authoring_point>[TN])\n"
+ "$";
final String string = "01-COS-SCIa-N\n"
+ "02-COS-SCIb-N\n"
+ "03-COS-SCIc-N\n"
+ "04-QQS-N\n"
+ "05-QQA-N\n"
+ "06-COS-LDW-N\n"
+ "07-COS-XYZ-N\n"
+ "08-CGA-SCI-N\n"
+ "11-COS-MATa-T\n"
+ "12-COS-MATb-T\n"
+ "13-COS-REAa-T\n"
+ "14-COS-REAb-T\n"
+ "15-COS-SCIa-T\n"
+ "16-COS-SCIb-T\n"
+ "17-CGA-SCI-T\n"
+ "18-CGA-MAT-T\n"
+ "19-CGA-REA-T\n"
+ "21-COSP-REAa-T\n"
+ "22-COSP-REAb-T\n"
+ "23-COSP-MATa-T\n"
+ "24-COSP-MATb-T\n"
+ "25-COSP-SCIa-N\n"
+ "26-COSP-SCIa-T\n"
+ "27-QQSP-N\n"
+ "28-QQAP-N\n"
+ "29-COSP-XYZ-N\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}