const regex = /^PT(?:(?<hour>\d+)H)?(?:(?<min>\d+)M)?(?:(?<sec>\d+)S)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^PT(?:(?<hour>\\d+)H)?(?:(?<min>\\d+)M)?(?:(?<sec>\\d+)S)?$', '')
const str = `PT1H32S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}