// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[\s"]*(\w+)[\s"]+(\w+)[\s"]+(\w+)[\s"]+(\w+)[\s"]+(\w+)[\s"]+(\w+)[\s"]+(\w+)[\s"]*"#).unwrap();
let string = "word1 word2 word3 word4 word5 \"word6\" \"word7\"
word1 word2 word3 word4 word5 \"word6\" \"word7\"
\"word1\" word2 \"word3\" word4 word5 \"word6\" \"word7\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}