$re = '/\((?=[^)a-z]*[a-z])[^\d)]*\d[^)]*\)/m';
$str = '(5) (dogs) (5 dogs) (dogs 5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);