$re = '/(Keto After 50 \$20 CPA\+FS)/m';
$str = 'Keto After 50 $20 CPA+FS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);