package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-?[pm][tbrlxy]?-)([248]){1} `)
var str = `p-8
pt-4
m-2
mx-4
-ml-4 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}