$re = '/@[\w]+/';
$str = 'text text @12321sыф-фы text text @aas test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);