using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\[(?=[^][]*]))[^]["",]*+(?:""[^""\\]*(?s:\\.[^""\\]*)*""[^]["",]*)*+\K,";
string input = @"[[""Sender"", ""mail@text.org""], [""Date"", ""Fri, 09 Jun 2017 13:29:22 +0000""]]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}