$re = '/(a\.\s*m\.|p\.\s*m\.)/';
$str = '34 10:55 a.m. 4 13:55 p. m.
10:55 a. m.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);