re = /^(?=\P{Ll}\p{Ll})(?=\P{Lu}*\p{Lu})(?=\P{N}*\p{N})(?=.*[^\p{L}\p{N}\p{C}]).{8,}$/
str = 'Ç!3abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end