use strict;
my $str = 'https://trends.google.com/trends/api/explore?hl=en-US&tz=-180&req=%7B%22comparisonItem%22:%5B%7B%22keyword%22:%22Mercedes%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D,%7B%22keyword%22:%22BMW%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D,%7B%22keyword%22:%22Audi%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D%5D,%22category%22:0,%22property%22:%22%22%7D&tz=-180
https://trends.google.com/trends/api/explore?hl=en-US&tz=-180&req=%7B%22comparisonItem%22:%5B%7B%22keyword%22:%22Mercedes%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D,%7B%22keyword%22:%22BMW%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D,%7B%22keyword%22:%22Audi%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D%5D,%22category%22:0,%22property%22:%22%22%7D&tz=-180
https://trends.google.com/trends/api/explore?hl=en-US&tz=-180&req=%7B%22comparisonItem%22:%5B%7B%22keyword%22:%22Mercedes%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D,%7B%22keyword%22:%22BMW%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D,%7B%22keyword%22:%22Audi%22,%22geo%22:%22%22,%22time%22:%22today+12-m%22%7D%5D,%22category%22:0,%22property%22:%22%22%7D&tz=-180
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHgSviwjES4tKMjOoqzulsmpTJkMH
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHgSviwjES4tKMjOoqzulsmpTJkMH
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHgSviwjES4tKMjOoqzulsmpTJkMH
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHoR3ZXTNX106x_9ChEfR5O9n2RS9
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHoR3ZXTNX106x_9ChEfR5O9n2RS9
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHoR3ZXTNX106x_9ChEfR5O9n2RS9
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHpXz1VjuZ5D-QVdesm9hTjUWP1a_
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHpXz1VjuZ5D-QVdesm9hTjUWP1a_
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHpXz1VjuZ5D-QVdesm9hTjUWP1a_
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D,%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D,%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22dataMode%22:%22PERCENTAGES%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHsLufGv3pfQ2BxPNw8dI-wIKkr_l
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D,%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D,%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22dataMode%22:%22PERCENTAGES%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHsLufGv3pfQ2BxPNw8dI-wIKkr_l
https://trends.google.com/trends/api/widgetdata/comparedgeo?hl=en-US&tz=-180&req=%7B%22geo%22:%7B%7D,%22comparisonItem%22:%5B%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D,%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D,%7B%22time%22:%222021-08-21+2022-08-21%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D%5D,%22resolution%22:%22COUNTRY%22,%22locale%22:%22en-US%22,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22dataMode%22:%22PERCENTAGES%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHsLufGv3pfQ2BxPNw8dI-wIKkr_l
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHv29rVS6IxcWgrBl8_9SJRhk_ORI
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHv29rVS6IxcWgrBl8_9SJRhk_ORI
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22BMW%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHv29rVS6IxcWgrBl8_9SJRhk_ORI
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHggCzy6uP3PrFpk88Ligm599j2Sk
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHggCzy6uP3PrFpk88Ligm599j2Sk
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Mercedes%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHggCzy6uP3PrFpk88Ligm599j2Sk
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHjukYobY26CMug0kICcK-hxqVSwD
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHjukYobY26CMug0kICcK-hxqVSwD
https://trends.google.com/trends/api/widgetdata/relatedsearches?hl=en-US&tz=-180&req=%7B%22restriction%22:%7B%22geo%22:%7B%7D,%22time%22:%222021-08-21+2022-08-21%22,%22originalTimeRangeForExploreUrl%22:%22today+12-m%22,%22complexKeywordsRestriction%22:%7B%22keyword%22:%5B%7B%22type%22:%22BROAD%22,%22value%22:%22Audi%22%7D%5D%7D%7D,%22keywordType%22:%22QUERY%22,%22metric%22:%5B%22TOP%22,%22RISING%22%5D,%22trendinessSettings%22:%7B%22compareTime%22:%222020-08-20+2021-08-20%22%7D,%22requestOptions%22:%7B%22property%22:%22%22,%22backend%22:%22IZG%22,%22category%22:0%7D,%22language%22:%22en%22,%22userCountryCode%22:%22UA%22,%22userConfig%22:%7B%22userType%22:%22USER_TYPE_LEGIT_USER%22%7D%7D&token=APP6_UEAAAAAYwOuHjukYobY26CMug0kICcK-hxqVSwD';
my $regex = qr/%22value%22:%22(?<value>[^%]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}